[rfk-dev] BUG: install scripts don't work straight out of git

David Griffith dgriffi at cs.csubak.edu
Thu Nov 8 17:42:55 PST 2012

On Thu, 8 Nov 2012, Peter A. H. Peterson wrote:

> Quoting David Griffith:
>> I haven't yet tried to build this new git-hosted rfk yet, so I tried and
>> got this:
>> marvin:/tmp/git/src$ ./robotfindskitten
>> There are only 2 NKIs available (user requested 20).
> It worked for me post install because I was running it from the
> rfk-git/ directory, where it was sourcing the local file
> "nki/vanilla.rfk". (This works if you run src/robotfindskitten post
> build but pre-install, or if you do make install and then run
> robotfindskitten [which is now in /usr/local/games/robotfindskitten].)
> When I run it outside of that directory I get the above behavior.
> So this is a bug.
> Where should the nki go? I'd suggest checking in
> /usr/share/robotfindskitten and probably ~/.robotfindskitten.

There are two problems here.  One is the program not finding the NKIs 
where it's looking.  I pushed some Makefile.am stuff and a slight 
alteration of robotfindskitten.c that will take care of this. 
SYSTEM_NKI_DIR is now set at compile-time.  Vanilla.nki is now installed 
to $(dataprefix)/games/robotfindskitten.  This led to NKIs being composed 
of pieces of Makefiles before I added the code to only parse *.nki.

The other problem is trickier and apparently involves something that works 
on a 64-bit machine but not 32-bit one.  I've been doing all my tinkering 
so far with a 32-bit machine.  I tried an AMD64 machine just now and 
things work fine.

David Griffith
dgriffi at cs.csubak.edu

A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?

More information about the rfk-dev mailing list