[rfk-dev] BUG: install scripts don't work straight out of git

Peter A. H. Peterson pedro at tastytronic.net
Thu Nov 8 11:01:11 PST 2012

Quoting David Griffith:
> I haven't yet tried to build this new git-hosted rfk yet, so I tried and 
> got this:
> marvin:/tmp/git/src$ ./robotfindskitten
> There are only 2 NKIs available (user requested 20).

It worked for me post install because I was running it from the
rfk-git/ directory, where it was sourcing the local file
"nki/vanilla.rfk". (This works if you run src/robotfindskitten post
build but pre-install, or if you do make install and then run
robotfindskitten [which is now in /usr/local/games/robotfindskitten].)

When I run it outside of that directory I get the above behavior.

So this is a bug.

Where should the nki go? I'd suggest checking in
/usr/share/robotfindskitten and probably ~/.robotfindskitten.

Peter A. H. Peterson
Graduate Student Researcher
Laboratory for Advanced Systems Research
University of California, Los Angeles

More information about the rfk-dev mailing list